Test.ical.ly Blog: Ist Gabelung symfony 1,5 wirklich eine realistische Option?

In dieser neuen post zu seinem Blog, Christian fragt sich, ob Gabelung der 1.x-Zweig der Symfony zu einem 1,5-Version erstellen, ist eine reale Möglichkeit.

Die Idee der Gabelung kam. Aber ist das wirklich passieren? Und macht es überhaupt Sinn? Was wäre der Vorteil der Gabelung symfony 1.4 und Weiterentwicklung der 1.x-Zweig werden?

Er schlägt vor, dass es vielleicht wert, denn die Branche ist derzeit stabil, es ist eine nachgewiesene Erfolgsbilanz hat, gibt es bereits mehrere Plugins zur Verfügung und es gibt einen Komfort unter den Entwicklern verwenden. Er fragt noch nach dem „Warum?“ Frage, wenn:

Nicht die Umstellung auf Symfony2 würde im Wesentlichen bedeuten, dass Sie diese Fehler zu akzeptieren [in 1.x]. Nun, auch wenn ich nicht zustimmen kann ich keinen Grund, gegen diese zu argumentieren. Als pragmatischer ist keine schlechte Sache als solche.

PHPDeveloper.org

Test.ical.ly Blog: PHP 5.4 mit Eigenschaften, Doctrine 2,2 und dann Symfony3?

Auf der Test.ical.ly Blog gibt es einen neuen Beitrag Blick in die nächste Version von PHP, 5.4, und was es für einige der beliebtesten Tools gibt bedeuten – insbesondere Symfony und Lehre.

Es sollte nicht lange dauern, bis die erste Alpha-Version von PHP 5.4 wird freigegeben und mit ihm wird es eine Menge neuer Features wie Array Dereferenzierung und Eigenschaften, um nur einige zu nennen sein. Was bedeutet das für den Fahrplänen der Lehre und Symfony bedeuten?

Er erwähnt die Experimente, die auf der Lehre Projekt, das eine der wichtigsten treibenden Kräfte hinter der Lehre 3 sein könnte vorgeschlagen werden. Er weist darauf hin, dass, solange Symfony bleibt nicht PHP 5.4-nur die Benutzer immer noch die Wahl der Lehre 2 oder 3. Es gibt zwei Probleme, betont er aber, dass könnte zu Problemen für beide Projekte verursachen – die Entscheidungen Symfony macht in Sachen wie seine Kurzanleitung und die DoctrinBundle vs Doctrine3Bundle Situation kommen konnte.

PHPDeveloper.org